summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-04-23 20:40:43 +0100
committerIan Lynagh <igloo@earth.li>2011-04-23 20:40:43 +0100
commitb8c25820084a46b1239ad7d87bee6391dd5c1017 (patch)
treebf541bac4775ebf92675aa0ee89efcbf0421bbdc /configure.ac
parent70b4e94b9423904e817c88e5b55732f7f3df9fbc (diff)
downloadhaskell-b8c25820084a46b1239ad7d87bee6391dd5c1017.tar.gz
Get CC_STAGE0 from the bootstrapping compiler
Rather than using the compiler that configure detects, we use the "GCC command" field from the --info output of the bootstrapping compiler (provided it is >= 7.1).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3eccc088b0..b126d1e0bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,6 +132,8 @@ if test "$WithGhc" != ""; then
GhcCanonVersion="$GhcMajVersion$GhcMinVersion2"
if test $GhcCanonVersion -ge 613; then ghc_ge_613=YES; else ghc_ge_613=NO; fi
AC_SUBST(ghc_ge_613)dnl
+
+ BOOTSTRAPPING_GHC_INFO_FIELD([CC_STAGE0],[GCC command],['$(CC)'])
fi
dnl ** Must have GHC to build GHC, unless --enable-hc-boot is on