summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-06-22 20:40:47 +0100
committerIan Lynagh <igloo@earth.li>2011-06-22 21:03:39 +0100
commit81c6dc7684178f9feb8884fe3049f42f43245786 (patch)
tree628fdd40b589dccaf63206dd3333f60c904172d6 /configure.ac
parent6ecb8d38b38e134760cf6fd88b078b224b2d8424 (diff)
downloadhaskell-81c6dc7684178f9feb8884fe3049f42f43245786.tar.gz
Share more code between configure.ac and distrib/configure.ac.in
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 1 insertions, 44 deletions
diff --git a/configure.ac b/configure.ac
index 9d3bb3d3bd..277f399b59 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,28 +207,6 @@ AC_CANONICAL_TARGET
FPTOOLS_SET_PLATFORM_VARS
-windows=NO
-exeext=''
-soext='.so'
-case $host in
-*-unknown-cygwin32)
- AC_MSG_WARN([GHC does not support the Cygwin target at the moment])
- AC_MSG_WARN([I'm assuming you wanted to build for i386-unknown-mingw32])
- exit 1
- ;;
-*-unknown-mingw32)
- windows=YES
- exeext='.exe'
- soext='.dll'
- ;;
-i386-apple-darwin|powerpc-apple-darwin)
- soext='.dylib'
- ;;
-x86_64-apple-darwin)
- soext='.dylib'
- ;;
-esac
-
# Testing if we shall enable shared libs support on Solaris.
# Anything older than SunOS 5.11 aka Solaris 11 (Express) is broken.
@@ -572,28 +550,7 @@ AC_SUBST(CONF_CPP_OPTS_STAGE0)
AC_SUBST(CONF_CPP_OPTS_STAGE1)
AC_SUBST(CONF_CPP_OPTS_STAGE2)
-if test "$windows" = YES
-then
- SettingsCCompilerCommand='$topdir/../mingw/bin/gcc.exe'
- SettingsCCompilerFlags=''
- SettingsPerlCommand='$topdir/../perl/perl.exe'
- SettingsDllWrapCommand='$topdir/../mingw/bin/dllwrap.exe'
- SettingsWindresCommand='$topdir/../mingw/bin/windres.exe'
- SettingsTouchCommand='$topdir/touch.exe'
-else
- SettingsCCompilerCommand="$WhatGccIsCalled"
- SettingsCCompilerFlags="$CONF_CC_OPTS_STAGE2"
- SettingsPerlCommand="$PerlCmd"
- SettingsDllWrapCommand="/bin/false"
- SettingsWindresCommand="/bin/false"
- SettingsTouchCommand='touch'
-fi
-AC_SUBST(SettingsCCompilerCommand)
-AC_SUBST(SettingsCCompilerFlags)
-AC_SUBST(SettingsPerlCommand)
-AC_SUBST(SettingsDllWrapCommand)
-AC_SUBST(SettingsWindresCommand)
-AC_SUBST(SettingsTouchCommand)
+FP_SETTINGS
dnl ** figure out how to do context diffs
FP_PROG_CONTEXT_DIFF