summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2012-06-17 21:49:18 +0100
committerIan Lynagh <igloo@earth.li>2012-06-17 21:49:18 +0100
commit7c987d10f012e2f175344fa2c28b36f073bda293 (patch)
treebf02e1d110e3eca4e373a0b0c98a158688c0352e /configure.ac
parentd0bfa810f6a5f92d672cf3822494701cb5aa3ac9 (diff)
downloadhaskell-7c987d10f012e2f175344fa2c28b36f073bda293.tar.gz
Switch to using the 'rubenvb' mingw builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f631fd3131..e1b4db0d73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -315,25 +315,24 @@ then
PATH=`pwd`/inplace/mingw/bin:$PATH inplace/mingw/bin/realgcc.exe driver/gcc/gcc.c driver/utils/cwrapper.c driver/utils/getLocation.c -Idriver/utils -o inplace/mingw/bin/gcc.exe
AC_MSG_NOTICE([In-tree mingw tree created])
fi
- mingwbin="$hardtop/inplace/mingw/bin/"
else
# NB. If you update the tarballs to a new version of gcc, don't
# forget to tweak the paths in driver/gcc/gcc.c.
if ! test -d inplace/mingw ||
- test inplace/mingw -ot ghc-tarballs/mingw64/mingw-w64-bin_*.zip
+ test inplace/mingw -ot ghc-tarballs/mingw64/*.tar.bz2
then
AC_MSG_NOTICE([Making in-tree mingw tree])
rm -rf inplace/mingw
mkdir inplace/mingw
(
cd inplace/mingw &&
- unzip ../../ghc-tarballs/mingw64/mingw-w64-bin_*.zip
+ tar -jxf ../../ghc-tarballs/mingw64/*.tar.bz2
)
AC_MSG_NOTICE([In-tree mingw tree created])
fi
- mingwbin="$hardtop/inplace/mingw/bin/x86_64-w64-mingw32-"
fi
+ mingwbin="$hardtop/inplace/mingw/bin/"
CC="${mingwbin}gcc.exe"
LD="${mingwbin}ld.exe"
NM="${mingwbin}nm.exe"