summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2017-04-25 09:28:40 -0400
committerBen Gamari <ben@smart-cactus.org>2017-04-25 15:35:17 -0400
commit66108864540601837ad77847f4062a670362361f (patch)
tree38b9fe8f3c0fd932374dc51d94fd25cdd428daf8 /configure.ac
parent688272ba31df7bd0a094c3d86d60f7b77b9f5268 (diff)
downloadhaskell-66108864540601837ad77847f4062a670362361f.tar.gz
Revert "Remove special casing of Windows in generic files"
This commit didn't consider the fact that binary distributions on Windows must have relative toolchain paths. This caused #13560. This reverts commit 48385cb2fc295eb8af9188cbe140142c1807d5a7 (except for a helpful comment).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5606080f63..194d37bd57 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,9 +177,13 @@ then
if test "$ghc_host_os" = "mingw32"
then
- # Canonicalise to <drive>:/path/to/ghc
- WithGhc=`cygpath -m "${WithGhc}"`
-
+ if test "${OSTYPE}" = "msys"
+ then
+ WithGhc=`echo "${WithGhc}" | sed "s#^/\([a-zA-Z]\)/#\1:/#"`
+ else
+ # Canonicalise to <drive>:/path/to/ghc
+ WithGhc=`cygpath -m "${WithGhc}"`
+ fi
echo "GHC path canonicalised to: ${WithGhc}"
fi
fi
@@ -374,8 +378,6 @@ then
NM="${mingwbin}nm.exe"
RANLIB="${mingwbin}ranlib.exe"
OBJDUMP="${mingwbin}objdump.exe"
- Windres="${mingwbin}windres.exe"
- DllWrap="${mingwbin}dllwrap.exe"
fp_prog_ar="${mingwbin}ar.exe"
# NB. Download the perl binaries if required
@@ -727,6 +729,7 @@ AC_SUBST(HaveDtrace)
AC_PATH_PROG(HSCOLOUR,HsColour)
# HsColour is passed to Cabal, so we need a native path
if test "$HostOS" = "mingw32" && \
+ test "${OSTYPE}" != "msys" && \
test "${HSCOLOUR}" != ""
then
# Canonicalise to <drive>:/path/to/gcc