summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Trommler <ptrommler@acm.org>2014-02-06 22:57:34 -0600
committerAustin Seipp <austin@well-typed.com>2014-02-06 22:57:34 -0600
commit298a25bdfd02bb591fde2dd0590bd7af81a91b94 (patch)
tree8c7d97c5a0611691e6a9619848210e940905ccfa /configure.ac
parent41cfc96b55a4a44953fc20aa72ef50789ba6ceab (diff)
downloadhaskell-298a25bdfd02bb591fde2dd0590bd7af81a91b94.tar.gz
Fix __thread detection (#8722)
Signed-off-by: Austin Seipp <austin@well-typed.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 33d4e7c515..e7fbc7f9d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,11 +867,11 @@ AC_COMPILE_IFELSE(
[ AC_LANG_SOURCE([[__thread int tester = 0;]]) ],
[
AC_MSG_RESULT(yes)
- AC_DEFINE([CC_SUPPORTS_TLS],[0],[Define to 1 if __thread is supported])
+ AC_DEFINE([CC_SUPPORTS_TLS],[1],[Define to 1 if __thread is supported])
],
[
AC_MSG_RESULT(no)
- AC_DEFINE([CC_SUPPORTS_TLS],[1],[Define to 1 if __thread is supported])
+ AC_DEFINE([CC_SUPPORTS_TLS],[0],[Define to 1 if __thread is supported])
])