summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsof <unknown>2005-03-04 18:26:49 +0000
committersof <unknown>2005-03-04 18:26:49 +0000
commitf1000ee3b4d504c7f1390a7af2e4c247676b9293 (patch)
tree8b34cc9319509086aa29a8797426878f05e92247 /configure.ac
parentcbc7228335a0489362d8f5deadaecacc8731a4ce (diff)
downloadhaskell-f1000ee3b4d504c7f1390a7af2e4c247676b9293.tar.gz
[project @ 2005-03-04 18:26:46 by sof]
Temper 'libm' testing -- if 'atan' is available straight from libc, no need to include libm. Merge to STABLE
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d243fa27f6..0a41966622 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1121,7 +1121,10 @@ else
fi
dnl ** check for math library
-AC_CHECK_LIB([m], [atan], [LIBS="-lm $LIBS"; LIBM="-lm"], [LIBM=])
+AC_CHECK_FUNC(atan,[fp_libm_not_needed=yes;LIBM=],[fp_libm_not_needed=dunno])
+if test x"$fp_libm_not_needed" = xdunno; then
+ AC_CHECK_LIB([m], [atan], [LIBS="-lm $LIBS"; LIBM="-lm"],[LIBM=])
+fi
AC_SUBST([LIBM])
dnl ################################################################
@@ -1263,6 +1266,7 @@ AC_TRY_COMPILE(,[__asm__ (".subsections_via_symbols");],
[Define to 1 if Apple-style dead-stripping is supported.])
],
[
+ AC_MSG_RESULT(no)
AC_DEFINE([HAVE_SUBSECTIONS_VIA_SYMBOLS],[0],
[Define to 1 if Apple-style dead-stripping is supported.])
])