summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2018-07-06 14:12:03 -0400
committerBen Gamari <ben@smart-cactus.org>2018-07-06 14:12:03 -0400
commit671537364ae09dc65d4bb1c646aa80e9c8f808df (patch)
tree86d951407775084fab25601b0d1a3912b800eb0e /configure.ac
parent8736715857d08cc1f88d766c257b39c05df20639 (diff)
downloadhaskell-671537364ae09dc65d4bb1c646aa80e9c8f808df.tar.gz
Revert "rts: Enable two-step allocator on FreeBSD"
This reverts commit 8736715857d08cc1f88d766c257b39c05df20639. I hadn't intended on merging this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 8 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 1976530df9..ac464b6d2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1182,23 +1182,22 @@ if test "$ac_cv_sizeof_void_p" -eq 8 ; then
if test "x$EnableLargeAddressSpace" = "xyes" ; then
if test "$ghc_host_os" = "darwin" ; then
use_large_address_space=yes
- elif test "$ghc_host_os" = "openbsd" ; then
- # as of OpenBSD 5.8 (2015), OpenBSD does not support mmap with MAP_NORESERVE.
- # The flag MAP_NORESERVE is supported for source compatibility reasons,
- # but is completely ignored by OS mmap
+ elif test "$ghc_host_os" = "openbsd" ; then
+ # as of OpenBSD 5.8 (2015), OpenBSD does not support mmap with MAP_NORESERVE.
+ # The flag MAP_NORESERVE is supported for source compatibility reasons,
+ # but is completely ignored by OS mmap
use_large_address_space=no
else
- AC_CHECK_DECLS([MAP_NORESERVE, MAP_GUARD, MADV_FREE, MADV_DONTNEED],[],[],
+ AC_CHECK_DECLS([MAP_NORESERVE, MADV_FREE, MADV_DONTNEED],[],[],
[
#include <unistd.h>
#include <sys/types.h>
#include <sys/mman.h>
#include <fcntl.h>
])
- if ( test "$ac_cv_have_decl_MAP_NORESERVE" = "yes" ||
- test "$ac_cv_have_decl_MAP_GUARD" = "yes" ) &&
- ( test "$ac_cv_have_decl_MADV_FREE" = "yes" ||
- test "$ac_cv_have_decl_MADV_DONTNEED" = "yes" ) ; then
+ if test "$ac_cv_have_decl_MAP_NORESERVE" = "yes" &&
+ test "$ac_cv_have_decl_MADV_FREE" = "yes" ||
+ test "$ac_cv_have_decl_MADV_DONTNEED" = "yes" ; then
use_large_address_space=yes
fi
fi