summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-02-11 18:42:44 +0000
committerIan Lynagh <igloo@earth.li>2011-02-11 18:42:44 +0000
commit650d644055ff9cf23891611efb578e4fff07a1d9 (patch)
treefb1f911dc3a86843292f1223fb1e8a1aeafc2501 /configure.ac
parent72c40bc5f2d193ebd89471f6e1f2a36b81042304 (diff)
downloadhaskell-650d644055ff9cf23891611efb578e4fff07a1d9.tar.gz
Fix platform detection in bindists
In a bindist, we generate files like the hsc2hs wrapper. This means we need to have the right values for the variables like CONF_GCC_LINKER_OPTS_STAGE1 which in turn means we need to know what platform we're on.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac67
1 files changed, 1 insertions, 66 deletions
diff --git a/configure.ac b/configure.ac
index 14a3ad154c..a0e0021496 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,72 +200,7 @@ AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
-# If no argument was given for a configuration variable, then discard
-# the guessed canonical system and use the configuration of the
-# bootstrapping ghc. If an argument was given, map it from gnu format
-# to ghc format.
-#
-# For why we do it this way, see: #3637, #1717, #2951
-
-if test "$build_alias" = ""
-then
- if test "${WithGhc}" != ""
- then
- build=$bootstrap_target
- echo "Build platform inferred as: $build"
- else
- echo "Can't work out build platform"
- exit 1
- fi
-
- BuildArch=`echo "$build" | sed 's/-.*//'`
- BuildVendor=`echo "$build" | sed -e 's/.*-\(.*\)-.*/\1/'`
- BuildOS=`echo "$build" | sed 's/.*-//'`
-else
- GHC_CONVERT_CPU([$build_cpu], [BuildArch])
- GHC_CONVERT_VENDOR([$build_vendor], [BuildVendor])
- GHC_CONVERT_OS([$build_os], [BuildOS])
-fi
-
-if test "$host_alias" = ""
-then
- if test "${WithGhc}" != ""
- then
- host=$bootstrap_target
- echo "Host platform inferred as: $host"
- else
- echo "Can't work out host platform"
- exit 1
- fi
-
- HostArch=`echo "$host" | sed 's/-.*//'`
- HostVendor=`echo "$host" | sed -e 's/.*-\(.*\)-.*/\1/'`
- HostOS=`echo "$host" | sed 's/.*-//'`
-else
- GHC_CONVERT_CPU([$host_cpu], [HostArch])
- GHC_CONVERT_VENDOR([$host_vendor], [HostVendor])
- GHC_CONVERT_OS([$host_os], [HostOS])
-fi
-
-if test "$target_alias" = ""
-then
- if test "${WithGhc}" != ""
- then
- target=$bootstrap_target
- echo "Target platform inferred as: $target"
- else
- echo "Can't work out target platform"
- exit 1
- fi
-
- TargetArch=`echo "$target" | sed 's/-.*//'`
- TargetVendor=`echo "$target" | sed -e 's/.*-\(.*\)-.*/\1/'`
- TargetOS=`echo "$target" | sed 's/.*-//'`
-else
- GHC_CONVERT_CPU([$target_cpu], [TargetArch])
- GHC_CONVERT_VENDOR([$target_vendor], [TargetVendor])
- GHC_CONVERT_OS([$target_os], [TargetOS])
-fi
+FPTOOLS_SET_PLATFORM_VARS
exeext=''
soext='.so'