summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2013-02-10 22:01:36 -0600
committerAustin Seipp <aseipp@pobox.com>2013-02-10 22:04:49 -0600
commit426a027f1043a4fe47759806ea11164c63d810f3 (patch)
tree014c53833dba5c601eb65a3c42c600b5db558251 /configure.ac
parent1affe46d6772f8b4a0dd6eb956e7e143b0a54501 (diff)
downloadhaskell-426a027f1043a4fe47759806ea11164c63d810f3.tar.gz
Distinguish between llvm-gcc/gcc in compiler name detection.
It uglifies the code a tiny bit but it's nice to know exactly what you're using. Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fa01e88713..9409900bf4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -986,14 +986,18 @@ echo ["\
"]
fi
-if test "$CC_CLANG_BACKEND" = "1"; then
-CNAME="clang "
+if test "x$CC_LLVM_BACKEND" = "x1"; then
+ if test "x$CC_CLANG_BACKEND" = "x1"; then
+ CompilerName="clang "
+ else
+ CompilerName="llvm-gcc "
+ fi
else
-CNAME="gcc "
+ CompilerName="gcc "
fi
echo ["\
- Using $CNAME : $WhatGccIsCalled
+ Using $CompilerName : $WhatGccIsCalled
which is version : $GccVersion
Building a cross compiler : $CrossCompiling