summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Petersen <petersen@redhat.com>2018-05-28 12:31:49 +0900
committerBen Gamari <ben@smart-cactus.org>2018-05-30 22:05:37 -0400
commit533d34516c795388d70f34123f14de1845f8b81b (patch)
tree7948acd7c4565dfd964ad7ecf80246a4205ef1d9 /configure.ac
parent15ece727d0cce777880ec2e3a1b3061f35dfce2c (diff)
downloadhaskell-533d34516c795388d70f34123f14de1845f8b81b.tar.gz
configure: Make sphinx-build version test work on recent versions
On Fedora: `/usr/libexec/sphinx-build --version` outputs `sphinx-build 1.7.2`. In bindir we actually have sphinx-build-2 and sphinx-build-3 (python2 and python3 versions), which output `sphinx-build-2 1.7.2` and `sphinx-build-3 1.7.2` respectively. Dunno what version others are using but at least this change should works for most versions I suppose.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 57d0943a07..21f9f1694d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -842,7 +842,7 @@ AC_PATH_PROG(SPHINXBUILD,sphinx-build)
AC_CACHE_CHECK([for version of sphinx-build], fp_cv_sphinx_version,
changequote(, )dnl
[if test -n "$SPHINXBUILD"; then
- fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/Sphinx\( (sphinx-build)\)\? v\?\([0-9]\.[0-9]\.[0-9]\)/\2/' | head -n1`;
+ fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/.* v\?\([0-9]\.[0-9]\.[0-9]\)/\1/' | head -n1`;
fi;
changequote([, ])dnl
])