summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2017-11-16 15:07:33 -0500
committerBen Gamari <ben@smart-cactus.org>2017-11-16 15:10:21 -0500
commitc7297342a4797ea36df8767d9c208cfb45de2d09 (patch)
tree69e67173540b5875c94dcfe25ed28599b5d0f0f2 /configure.ac
parent2da7813b771edcb3efb1b067b986d10f5de4beaf (diff)
downloadhaskell-c7297342a4797ea36df8767d9c208cfb45de2d09.tar.gz
configure: Fix incorrect quoting
This is a regression affecting Windows introduced by 3bed4aa703c41ccbd310496420fbb71afdfd99e7.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3a7375db23..d67e5bd9a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -922,7 +922,11 @@ AC_CHECK_DECLS([ctime_r], , ,
#include <time.h>])
dnl ** check for mingwex library
-AC_CHECK_LIB([mingwex], [closedir], [AC_SUBST([HaveLibMingwEx],[YES])] [AC_SUBST(CabalMingwex),[True]], [AC_SUBST([HaveLibMingwEx],[NO])] [AC_SUBST([CabalMingwex],[False])])
+AC_CHECK_LIB(
+ [mingwex],
+ [closedir],
+ [AC_SUBST([HaveLibMingwEx],[YES])] [AC_SUBST([CabalMingwex],[True])],
+ [AC_SUBST([HaveLibMingwEx],[NO])] [AC_SUBST([CabalMingwex],[False])])
if test $HaveLibMingwEx = YES ; then
AC_DEFINE([HAVE_MINGWEX], [1], [Define to 1 if you have the mingwex library.])