summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMoritz Angermann <moritz.angermann@gmail.com>2017-06-08 14:59:20 -0400
committerBen Gamari <ben@smart-cactus.org>2017-06-08 15:35:58 -0400
commitcd8f4b9917c6fd9aa894ecafc505224e41b947fa (patch)
tree1232a98a4e1bca2dcf575c62eeb1e944c759e4f3 /configure.ac
parent1c83fd814b12754be8af211a387cec906ca198b3 (diff)
downloadhaskell-cd8f4b9917c6fd9aa894ecafc505224e41b947fa.tar.gz
Check target libtool
This will qualify the libtool with the target, e.g. arch-vendor-os-libtool, instead of simply using libtool. Reviewers: austin, hvr, bgamari Reviewed By: bgamari Subscribers: Ericson2314, ryantrinkle, rwbarton, thomie, erikd Differential Revision: https://phabricator.haskell.org/D3617
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45b2ab3b62..a32e6b408c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -569,6 +569,11 @@ fi
RanlibCmd="$RANLIB"
RANLIB="$RanlibCmd"
+dnl ** which libtool to use?
+dnl --------------------------------------------------------------
+AC_CHECK_TARGET_TOOL([LIBTOOL], [libtool])
+LibtoolCmd="$LIBTOOL"
+LIBTOOL="$LibtoolCmd"
# Here is where we re-target which specific version of the LLVM
# tools we are looking for. In the past, GHC supported a number of
@@ -1250,6 +1255,7 @@ echo "\
ar : $ArCmd
ld : $LdCmd
nm : $NmCmd
+ libtool : $LibtoolCmd
objdump : $ObjdumpCmd
ranlib : $RanlibCmd
windres : $Windres