summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDarshan Kapashi <darshan@fb.com>2016-10-21 12:03:19 -0400
committerBen Gamari <ben@smart-cactus.org>2016-10-22 12:20:59 -0400
commit1050e46b5b1640a475fa2fa67616cda8d31308e2 (patch)
tree57b8d4f9f5b293136bd4364cc2a614fa0255dc2d /configure.ac
parentacc98510c5e32474b0bba9fba54e78df2b11078c (diff)
downloadhaskell-1050e46b5b1640a475fa2fa67616cda8d31308e2.tar.gz
rts: configure.ac should populate HAVE_LIBNUMA instead of USE_LIBNUMA
Code in rts/ which deals with numa checks for `#if HAVE_LIBNUMA`, however this macro is not populated during `./configure`. https://phabricator.haskell.org/D2329 changed this code last and we instead set `USE_LIBNUMA` which fails to setup numa correctly. Test Plan: From main directory in ghc, ./configure && make clean && make boot && make cd nofib/parallel/queens ../../../inplace/bin/ghc-stage2 Main.hs -rtsopts -threaded ./Main 15 +RTS -N24 -s -A64m --numa This fails before this patch with Main: --numa: OS reports NUMA is not available After the fix, it works as expected. Run the validation script, ./validate (It fails with an error in `compiler/utils/Util.hs` saying `GHC.Stack.CallStack` not found, once I remove this 1 line from this file , the script works) Reviewers: hvr, austin, bgamari, erikd, simonmar Reviewed By: erikd, simonmar Subscribers: mpickering, thomie, erikd, niteria Differential Revision: https://phabricator.haskell.org/D2620 GHC Trac Issues: #12741
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 629624ab05..5decd2418a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1070,7 +1070,7 @@ AC_CHECK_HEADERS([numa.h numaif.h])
if test "$ac_cv_header_numa_h$ac_cv_header_numaif_h" = "yesyes" ; then
AC_CHECK_LIB(numa, numa_available,HaveLibNuma=1)
fi
-AC_DEFINE_UNQUOTED([USE_LIBNUMA], [$HaveLibNuma], [Define to 1 if you have libnuma])
+AC_DEFINE_UNQUOTED([HAVE_LIBNUMA], [$HaveLibNuma], [Define to 1 if you have libnuma])
dnl ** Documentation
dnl --------------------------------------------------------------