summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2009-12-01 19:05:44 +0000
committerIan Lynagh <igloo@earth.li>2009-12-01 19:05:44 +0000
commit86876c30e19d9b2c699bdff44f5156b9afe6adcf (patch)
tree8bc2a6e253be4c37e56fe7c815416aaa7bc25d76 /configure.ac
parenta8cbb796233e44509cba2afde3081e844b7b6feb (diff)
downloadhaskell-86876c30e19d9b2c699bdff44f5156b9afe6adcf.tar.gz
Use dlltool from the in-tree mingw installation
We only use dlltool on Windows, and this way we don't require that the user has it installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index c249b9adbc..2e87ea5d5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -437,21 +437,6 @@ FP_ARG_WITH_PATH_GNU_PROG([LD], [ld])
LdCmd="$LD"
AC_SUBST([LdCmd])
-dnl ** Check for dlltool on Windows
-dnl --------------------------------------------------------------
-case $HostOS_CPP in
-cygwin32|mingw32)
- AC_PATH_PROG(DlltoolCmd,dlltool)
- if test -z "$DlltoolCmd"; then
- echo "Can't find dlltool in your path, can't make DLLs."
- exit 1
- fi
- ;;
-*)
- AC_SUBST(DlltoolCmd,"")
- ;;
-esac
-
dnl ** Which nm to use?
dnl --------------------------------------------------------------
FP_ARG_WITH_PATH_GNU_PROG([NM], [nm])