summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2010-05-25 22:16:16 +0000
committerIan Lynagh <igloo@earth.li>2010-05-25 22:16:16 +0000
commit88223168614ea60a5d76a264f6c11837b6c5a443 (patch)
treeb7dd012ae44893ef4cfe89a3f9321128b25a2bcb /configure.ac
parent84e10e6c110f218991fc9573bcb16aa2e647e02c (diff)
downloadhaskell-88223168614ea60a5d76a264f6c11837b6c5a443.tar.gz
Add configure flags for the location of GMP includes/library; fixes #4022
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 28e380b719..c0ca168787 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,22 @@ AC_ARG_WITH([iconv-libraries],
AC_SUBST(ICONV_INCLUDE_DIRS)
AC_SUBST(ICONV_LIB_DIRS)
+dnl Allow to specify gmp options to the toplevel configure script
+dnl so they can be properly passed to sub-builds.
+
+AC_ARG_WITH([gmp-includes],
+ [AC_HELP_STRING([--with-gmp-includes],
+ [directory containing gmp.h])],
+ [GMP_INCLUDE_DIRS=$withval])
+
+AC_ARG_WITH([gmp-libraries],
+ [AC_HELP_STRING([--with-gmp-libraries],
+ [directory containing gmp library])],
+ [GMP_LIB_DIRS=$withval])
+
+AC_SUBST(GMP_INCLUDE_DIRS)
+AC_SUBST(GMP_LIB_DIRS)
+
dnl--------------------------------------------------------------------
dnl * Choose host(/target/build) platform
dnl--------------------------------------------------------------------