summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-01-04 22:00:13 +0000
committerIan Lynagh <igloo@earth.li>2011-01-04 22:00:13 +0000
commitf0e3d7904df76f35676e105ed63e7b4eb961773a (patch)
tree7daaa320da46a3be56448b5b4096bbafb082231a /configure.ac
parentdaee7323b13a3f35cead6b94092adbcdfdcad568 (diff)
downloadhaskell-f0e3d7904df76f35676e105ed63e7b4eb961773a.tar.gz
Define cTargetArch and start to use it rather than ifdefs
Using Haskell conditionals means the compiler sees all the code, so there should be less rot of code specific to uncommon arches. Code for other platforms should still be optimised away, although if we want to support targetting other arches then we'll need to compile it for-real anyway.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a18f2f7a4d..5bf773b6c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,6 +282,7 @@ x86_64-apple-darwin)
;;
esac
+# Sync this with cTargetArch in compiler/ghc.mk
checkArch() {
case $1 in
alpha|arm|hppa|hppa1_1|i386|ia64|m68k|mips|mipseb|mipsel|powerpc|powerpc64|rs6000|s390|sparc|sparc64|vax|x86_64)