summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTamar Christina <tamar@zhox.com>2016-05-31 20:12:55 +0200
committerTamar Christina <tamar@zhox.com>2016-06-09 11:32:02 +0200
commit48385cb2fc295eb8af9188cbe140142c1807d5a7 (patch)
tree3f481bd6d33791dc32a995153b06ab16a6c120ca /configure.ac
parent11ff1df8a7c25485c9c7508d65bcb380e592010d (diff)
downloadhaskell-48385cb2fc295eb8af9188cbe140142c1807d5a7.tar.gz
Remove special casing of Windows in generic files
Summary: Remove some Windows specific code from the .m4 files and have configure figure it out. Unfortunately touchy can't be removed since there is no mingw build of coreutils. Only msys builds which would give us a dependency on the msys runtime. Reviewers: hvr, austin, thomie, bgamari Reviewed By: thomie, bgamari Subscribers: thomie, erikd, #ghc_windows_task_force Differential Revision: https://phabricator.haskell.org/D2248
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 15561d059f..d7eb7380cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,13 +177,9 @@ then
if test "$ghc_host_os" = "mingw32"
then
- if test "${OSTYPE}" = "msys"
- then
- WithGhc=`echo "${WithGhc}" | sed "s#^/\([a-zA-Z]\)/#\1:/#"`
- else
- # Canonicalise to <drive>:/path/to/ghc
- WithGhc=`cygpath -m "${WithGhc}"`
- fi
+ # Canonicalise to <drive>:/path/to/ghc
+ WithGhc=`cygpath -m "${WithGhc}"`
+
echo "GHC path canonicalised to: ${WithGhc}"
fi
fi
@@ -366,6 +362,8 @@ then
NM="${mingwbin}nm.exe"
RANLIB="${mingwbin}ranlib.exe"
OBJDUMP="${mingwbin}objdump.exe"
+ Windres="${mingwbin}windres.exe"
+ DllWrap="${mingwbin}dllwrap.exe"
fp_prog_ar="${mingwbin}ar.exe"
# NB. Download the perl binaries if required
@@ -733,7 +731,6 @@ AC_SUBST(HaveDtrace)
AC_PATH_PROG(HSCOLOUR,HsColour)
# HsColour is passed to Cabal, so we need a native path
if test "$HostOS" = "mingw32" && \
- test "${OSTYPE}" != "msys" && \
test "${HSCOLOUR}" != ""
then
# Canonicalise to <drive>:/path/to/gcc