summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2019-06-22 10:13:51 +1000
committerMarge Bot <ben+marge-bot@smart-cactus.org>2019-06-24 01:11:46 -0400
commit71aca77c780dad8496054a06a7fe65704a13a742 (patch)
tree9c809e4619fecd7662b56cc9ce07720ea669c12c /configure.ac
parent9bbcc3be51180dcefde0c89daf8ad6f69c680b40 (diff)
downloadhaskell-71aca77c780dad8496054a06a7fe65704a13a742.tar.gz
Fixes for LLVM 7
LLVM version numberinf changed recently. Previously, releases were numbered 4.0, 5.0 and 6.0 but with version 7, they dropped the redundant ".0". Fix requires for Llvm detection and some code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e1b2342d75..751b059f2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -628,7 +628,7 @@ AC_SUBST([LibtoolCmd])
# tools we are looking for. In the past, GHC supported a number of
# versions of LLVM simultaneously, but that stopped working around
# 3.5/3.6 release of LLVM.
-LlvmVersion=7.0
+LlvmVersion=7
AC_SUBST([LlvmVersion])
sUPPORTED_LLVM_VERSION=$(echo \($LlvmVersion\) | sed 's/\./,/')
AC_DEFINE_UNQUOTED([sUPPORTED_LLVM_VERSION], ${sUPPORTED_LLVM_VERSION}, [The supported LLVM version number])