summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHerbert Valerio Riedel <hvr@gnu.org>2015-12-04 09:15:29 +0100
committerHerbert Valerio Riedel <hvr@gnu.org>2015-12-04 10:01:52 +0100
commit7af29da05d2e5a5e311a5f73f20d0f232035973b (patch)
treef37df9bb14fa7baccf3c017fe61e1e267fad8420 /configure.ac
parent99d01e1d82505e168224043d10e7ce116f5617ae (diff)
downloadhaskell-7af29da05d2e5a5e311a5f73f20d0f232035973b.tar.gz
Use Autoconf's AC_USE_SYSTEM_EXTENSIONS
This takes care of setting feature test macros (i.e. let Autoconf decide when those can be set safely) to allow subsequent Autoconf tests to better detect available OS features. This also includes a submodule update of unix which enables the use of `AC_USE_SYSTEM_EXTENSIONS` in there as well. Specifically, this takes care of setting `_GNU_SOURCE` (which allows to remove two occurences where it's set manually) and `_ALL_SOURCE` (which fixes issues on AIX). See also https://www.gnu.org/software/autoconf/manual/autoconf-2.69/html_node/Posix-Variants.html for details. At some point we may want to reconsider the purpose of "rts/PosixSource.h" and rely more on Autoconf instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3889cea904..57d877ab58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,9 @@ dnl #define SIZEOF_CHAR 0
dnl recently.
AC_PREREQ([2.60])
+dnl make extensions visible to allow feature-tests to detect them lateron
+AC_USE_SYSTEM_EXTENSIONS
+
# -------------------------------------------------------------------------
# Prepare to generate the following header files
#