summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSylvain Henry <sylvain@haskus.fr>2020-02-27 12:59:02 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2020-03-02 17:14:38 -0500
commit2a2f51d79f145e015cc089d97cf71c19dd27bee4 (patch)
tree24e6859abf947bc2e08072282a27539f0697b2ad /configure.ac
parent7c0c76fb1a11532076a0342655a9c889a2a12768 (diff)
downloadhaskell-2a2f51d79f145e015cc089d97cf71c19dd27bee4.tar.gz
Use configure script to detect that we should use in-tree GMP on Windows
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7785884296..fcc0a75ca6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -458,6 +458,12 @@ FP_ICONV
FP_GMP
FP_CURSES
+dnl On Windows we force in-tree GMP build until we support dynamic linking
+if test "$HostOS" = "mingw32"
+then
+ GMP_FORCE_INTREE="YES"
+fi
+
XCODE_VERSION()
@@ -1453,6 +1459,7 @@ echo "\
Building a cross compiler : $CrossCompiling
Unregisterised : $Unregisterised
TablesNextToCode : $TablesNextToCode
+ Build GMP in tree : $GMP_FORCE_INTREE
hs-cpp : $HaskellCPPCmd
hs-cpp-flags : $HaskellCPPArgs
ar : $ArCmd