summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2007-04-10 21:52:52 +0000
committerIan Lynagh <igloo@earth.li>2007-04-10 21:52:52 +0000
commitbdd44abe63ce79b32e3570e846afabad2024cd09 (patch)
treeb25fb1b882fff0ee82466475936e95ae67951c1e /configure.ac
parenteaa67895758acd3ea1546c8d026a1ed67d5eae25 (diff)
downloadhaskell-bdd44abe63ce79b32e3570e846afabad2024cd09.tar.gz
Use a boot script instead of having autoreconf recurse
It used to be the case that autoreconf in the root would also autoreconf in any libraries that need it, and ./configure in the root would also configure all the libraries. However, cabal now configures the libraries, so they were getting configured twice. Thus now a small shellscript, boot, autoreconfs the root and all libraries that need it, and ./configure in the root doesn't configure the libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index dce5a07d22..70936e2bbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,13 +44,6 @@ dnl We need 2.50 due to the use of AC_SYS_LARGEFILE and AC_MSG_NOTICE.
dnl We need 2.52 due to the use of AS_TR_CPP and AS_TR_SH.
AC_PREREQ([2.52])
-dnl * Declare subdirectories that have a private configure script
-dnl
-dnl After the toplevel configuration is complete, the script will recurse into
-dnl these subdirectories if they exist. The use of a cache file makes repeated
-dnl checks cheap.
-AC_CONFIG_SUBDIRS([libraries])
-
# -------------------------------------------------------------------------
# Prepare to generate the following header files
#