summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Miedema <thomasmiedema@gmail.com>2016-01-04 18:29:49 +0100
committerBen Gamari <ben@smart-cactus.org>2016-01-04 18:29:50 +0100
commit4c56ad36ee0d1f8b6f1b2bc0d8fff1c9acd1a389 (patch)
treec572b428254c5fd605f05caa349c2560c696ef2b /configure.ac
parent5c10f5ce8831a59f67f2c42ed5d7cf5be10c0860 (diff)
downloadhaskell-4c56ad36ee0d1f8b6f1b2bc0d8fff1c9acd1a389.tar.gz
Build system: delete ghc-pwd
On Windows, with msys2, `pwd` works (as can be seen by the use of `pwd` that slipped into the validate script), so there is really no need for `ghc-pwd` anymore. Test Plan: try it Reviewers: austin, bgamari, Phyx Reviewed By: Phyx Subscribers: Phyx, erikd Differential Revision: https://phabricator.haskell.org/D1731
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 042b417ff1..ab82bb0bfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,8 @@ AC_INIT([The Glorious Glasgow Haskell Compilation System], [8.1], [glasgow-haske
# checkout), then we ship a file 'VERSION' containing the full version
# when the source distribution was created.
+FP_FIND_ROOT
+
if test ! -f mk/config.h.in; then
echo "mk/config.h.in doesn't exist: perhaps you haven't run 'perl boot'?"
exit 1
@@ -258,10 +260,6 @@ AC_ARG_WITH(hc,
)
AC_SUBST(WithHc)
-# This uses GHC, so put it after the "GHC is required" check above:
-FP_INTREE_GHC_PWD
-FP_FIND_ROOT
-
fail() {
echo >&2
echo "$1" >&2