summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Z. Yang <ezyang@cs.stanford.edu>2014-08-13 11:30:26 +0100
committerEdward Z. Yang <ezyang@cs.stanford.edu>2014-08-13 15:33:14 +0100
commit2272c50a61c3dc43edf35b3eeb7997cc0f47eaf3 (patch)
tree3312733d435a38cff36bb700c1a73de53fe7571a /configure.ac
parent5e46e1f5323a7fc09e9bbd9023d5c63e144e1ad3 (diff)
downloadhaskell-2272c50a61c3dc43edf35b3eeb7997cc0f47eaf3.tar.gz
Explicitly version test for package key support.
Signed-off-by: Edward Z. Yang <ezyang@cs.stanford.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 533ea297e9..378578a50b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,11 @@ FP_COMPARE_VERSIONS([$GhcVersion],[-gt],[7.7],
CMM_SINK_BOOTSTRAP_IS_NEEDED=NO)
AC_SUBST(CMM_SINK_BOOTSTRAP_IS_NEEDED)
+FP_COMPARE_VERSIONS([$GhcVersion],[-lt],[7.9],
+ SUPPORTS_PACKAGE_KEY=NO,
+ SUPPORTS_PACKAGE_KEY=YES)
+AC_SUBST(SUPPORTS_PACKAGE_KEY)
+
# GHC is passed to Cabal, so we need a native path
if test "${WithGhc}" != ""
then