summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <bgamari.foss@gmail.com>2016-11-10 13:18:09 -0500
committerBen Gamari <ben@smart-cactus.org>2016-11-10 13:21:09 -0500
commitbae4a55b1fb403f610b4b55a1b6fb3f03e9c2026 (patch)
tree114191a265045a30ea86dcaa81e8e9c107fca41a /configure.ac
parent9030d8e4dc321dbcd32baae33f150b4e7c8ed141 (diff)
downloadhaskell-bae4a55b1fb403f610b4b55a1b6fb3f03e9c2026.tar.gz
Pass -no-pie to GCC
Certain distributions (e.g. Debian and Ubuntu) have enabled PIE be default in their GCC packaging. This breaks our abuse of GCC as a linker which requires that we pass -Wl,-r, which is incompatible with PIE (since the former implies that we are generating a relocatable object file and the latter an executable). Test Plan: Validate Reviewers: hvr, austin Subscribers: rwbarton, thomie, erikd Differential Revision: https://phabricator.haskell.org/D2691 GHC Trac Issues: #12759
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70c4447bb9..678fa2e609 100644
--- a/configure.ac
+++ b/configure.ac
@@ -608,6 +608,9 @@ dnl If gcc, make sure it's at least 3.0
dnl
FP_GCC_VERSION
+dnl ** See whether gcc supports -no-pie
+FP_GCC_SUPPORTS_NO_PIE
+
dnl ** look to see if we have a C compiler using an llvm back end.
dnl
FP_CC_LLVM_BACKEND