summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsof <unknown>1999-05-04 08:35:12 +0000
committersof <unknown>1999-05-04 08:35:12 +0000
commit88ffee68c9170decde439fae25e896a6dfa8a1d7 (patch)
tree9df21387545d97ed3c5f72daf1f18f9a633ecb1f /configure.in
parent5aebbfcee0f6ebd79e08e9a4e0a108023b59e5ae (diff)
downloadhaskell-88ffee68c9170decde439fae25e896a6dfa8a1d7.tar.gz
[project @ 1999-05-04 08:35:12 by sof]
New option: --enable-win32-dlls
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6e174afec5..53d3cfb143 100644
--- a/configure.in
+++ b/configure.in
@@ -168,6 +168,11 @@ i[[3456]]86-*-mingw32*)
HostVendor_CPP='unknown'
HostOS_CPP='mingw32'
exeext='.exe'
+ # We assume you're using mingw32 via the gcc that comes
+ # with cygwin, and not the native port, so let's augment
+ # the gcc command-line used here with -mno-cygwin to
+ # arrange for good things to happen.
+ CFLAGS="-mno-cygwin $CFLAGS"
;;
m68k-next-nextstep2)
HostPlatform_CPP='m68k_next_nextstep2'
@@ -338,6 +343,30 @@ AC_ARG_ENABLE(hc-boot,
AC_SUBST(BootingFromHc)
+dnl ** Enable the construction of Win32 DLLs?
+dnl --------------------------------------------------------------
+AC_ARG_ENABLE(win32-dlls,
+[ --enable-win32-dlls
+ If on a Win32 platform running mingw32/cygwin, enable the
+ construction of DLLs containing ghc-compiled code.
+],
+[
+case $HostOS_CPP in
+cygwin32) ;;
+mingw32) ;;
+*) echo "Unrecognised win32 platform: $HostPlatform"
+ exit 1
+ ;;
+esac
+EnableWin32DLLs=YES
+],
+[EnableWin32DLLs=NO]
+)
+AC_SUBST(EnableWin32DLLs)
+if test x"$EnableWin32DLLs" = "xYES" ; then
+ AC_DEFINE(HAVE_WIN32_DLL_SUPPORT)
+fi
+
dnl --------------------------------------------------------------
dnl End of configure script option section
dnl --------------------------------------------------------------