summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsof <unknown>2001-11-08 18:51:03 +0000
committersof <unknown>2001-11-08 18:51:03 +0000
commit8c08b1a318252bfe4f66762dbef40712a14bb337 (patch)
treed887231bd47593e0c3e919e6426a39a05a085e2c /configure.in
parentf8bd123ff75666c83061a891000d745ede3b55f5 (diff)
downloadhaskell-8c08b1a318252bfe4f66762dbef40712a14bb337.tar.gz
[project @ 2001-11-08 18:51:03 by sof]
hardtop_plat: escape those backslashes (exponentially so).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 0eda0d3bee..6aadb65ba5 100644
--- a/configure.in
+++ b/configure.in
@@ -339,13 +339,10 @@ AC_SUBST(exeext)
#
# The native format for 'hardtop' (i.e., right kind of slashes on a Win32 box).
-#
+# (but with b-slashes being escaped).
case $HostPlatform in
- i386-unknown-mingw32)
- hardtop_plat=`cygpath -w ${hardtop}`
- ;;
- i386-unknown-cygwin32)
- hardtop_plat=`cygpath -w ${hardtop}`
+ i386-unknown-mingw32 | i386-unknown-cygwin32)
+ hardtop_plat=`cygpath -w ${hardtop} | sed -e 's@\\\\@\\\\\\\\@g' `
;;
*)
hardtop_plat=${hardtop}