summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsof <unknown>2003-05-29 14:39:31 +0000
committersof <unknown>2003-05-29 14:39:31 +0000
commita7d8f43718b167689c0a4a4c23b33a325e0239f1 (patch)
tree5da294fb5b8f5ad147c498115df6a024887cdeea /configure.in
parentc4282406d8cf94962f41ebd7eaa7abf4ee23ac7d (diff)
downloadhaskell-a7d8f43718b167689c0a4a4c23b33a325e0239f1.tar.gz
[project @ 2003-05-29 14:39:26 by sof]
Support for interop'ing with .NET via FFI declarations along the lines of what Hugs98.NET offers, see http://haskell.org/pipermail/cvs-hugs/2003-March/001723.html for FFI decl details. To enable, configure with --enable-dotnet + have a look in ghc/rts/dotnet/Makefile for details of what tools are needed to build the .NET interop layer (tools from VS.NET / Framework SDK.) The commit doesn't include some library additions + wider-scale testing is required before this extension can be regarded as available for general use. 'foreign import dotnet' is currently only supported by the C backend.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9ab0b3e451..9d47366ada 100644
--- a/configure.in
+++ b/configure.in
@@ -539,6 +539,18 @@ AC_ARG_ENABLE(hopengl,
)
AC_SUBST(GhcLibsWithHOpenGL)
+dnl ** .NET interop support?
+dnl --------------------------------------------------------------
+AC_ARG_ENABLE(dotnet,
+[ --enable-dotnet
+ Build .NET interop layer.
+],
+[DotnetSupport=YES],
+[DotnetSupport=NO]
+)
+AC_DEFINE(WANT_DOTNET_SUPPORT)
+AC_SUBST(DotnetSupport)
+
dnl --------------------------------------------------------------
dnl End of configure script option section
dnl --------------------------------------------------------------