summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorross <unknown>2005-02-01 00:52:22 +0000
committerross <unknown>2005-02-01 00:52:22 +0000
commita69fb32fa5d0fd84caf228af006d2aad1d0b3534 (patch)
tree8ea7203bba051cd7343d81e107fc1c9025b72c77 /libraries/base/configure.ac
parenta24f30ed0716a73bf7cf896349b01329ec15ad22 (diff)
downloadhaskell-a69fb32fa5d0fd84caf228af006d2aad1d0b3534.tar.gz
[project @ 2005-02-01 00:52:20 by ross]
more regex test down to libraries/base
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index 570ad366b9..349f44577d 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -15,6 +15,11 @@ AC_CHECK_HEADERS([ctype.h fcntl.h signal.h sys/resource.h termios.h time.h])
# rlim_t, because it will affect the result of that test.
AC_SYS_LARGEFILE
+dnl ** check for POSIX regex
+HavePosixRegex=NO
+AC_CHECK_HEADERS([regex.h], [AC_CHECK_FUNCS(regcomp, [HavePosixRegex=YES])])
+AC_SUBST(HavePosixRegex)
+
dnl ** check for wide-char classifications
dnl FreeBSD has an emtpy wctype.h, so test one of the affected
dnl functions if it's really there.
@@ -85,6 +90,6 @@ case "$target" in
esac
AC_SUBST([EXTRA_LIBS])
-AC_CONFIG_FILES([base.buildinfo])
+AC_CONFIG_FILES([config.mk base.buildinfo])
AC_OUTPUT