summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorMatthias Kilian <kili@outback.escape.de>2009-08-26 15:44:06 +0000
committerMatthias Kilian <kili@outback.escape.de>2009-08-26 15:44:06 +0000
commita05ddfe879abbb3ec47193f3e63d3ccd3adfc5ba (patch)
tree2370485a376e5deed465285e171f71aa86e204dc /libraries/base/configure.ac
parent85376623ca4bf5d8033a5d2e3f0c1f4aa5b3ab5a (diff)
downloadhaskell-a05ddfe879abbb3ec47193f3e63d3ccd3adfc5ba.tar.gz
Allow for configurable iconv include and library locations.
This should help to fix the build on OpenBSD.
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index 91c72a5205..26cd8903cb 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -32,6 +32,25 @@ AC_CHECK_FUNCS([lstat])
AC_CHECK_FUNCS([getclock getrusage times])
AC_CHECK_FUNCS([_chsize ftruncate])
+dnl--------------------------------------------------------------------
+dnl * Deal with arguments telling us iconv is somewhere odd
+dnl--------------------------------------------------------------------
+
+AC_ARG_WITH([iconv-includes],
+ [AC_HELP_STRING([--with-iconv-includes],
+ [directory containing iconv.h])],
+ [ICONV_INCLUDE_DIRS=$withval; CPPFLAGS="-I$withval"],
+ [ICONV_INCLUDE_DIRS=])
+
+AC_ARG_WITH([iconv-libraries],
+ [AC_HELP_STRING([--with-iconv-libraries],
+ [directory containing iconv library])],
+ [ICONV_LIB_DIRS=$withval; LDFLAGS="-L$withval"],
+ [ICONV_LIB_DIRS=])
+
+AC_SUBST(ICONV_INCLUDE_DIRS)
+AC_SUBST(ICONV_LIB_DIRS)
+
# map standard C types and ISO types to Haskell types
FPTOOLS_CHECK_HTYPE(char)
FPTOOLS_CHECK_HTYPE(signed char)