summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2019-10-22 16:07:26 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2019-10-29 03:48:55 -0400
commit7d3a15c7afa25f32ba3a7570f9174aeeedb90bef (patch)
treeb7c45b9edb92f7e1456bb8c9b5d24008b062b2fa /libraries/base/configure.ac
parentd7cedd9d74e51ae9704802af6eb4775a16e59039 (diff)
downloadhaskell-7d3a15c7afa25f32ba3a7570f9174aeeedb90bef.tar.gz
base: Fix open-file locking
The OFD locking path introduced in 3b784d440d4b01b4c549df7c9a3ed2058edfc780 due to #13945 appears to have never actually worked but we never noticed due to an oversight in the autoconf check. Fix it. Thanks to Oleg Grenrus for noticing this.
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index 631e921423..d34224acc7 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -72,6 +72,9 @@ fi
# Linux open file descriptor locks
AC_CHECK_DECL([F_OFD_SETLK], [
AC_DEFINE([HAVE_OFD_LOCKING], [1], [Define if you have open file descriptor lock support.])
+], [], [
+ #include <unistd.h>
+ #include <fcntl.h>
])
# flock