summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorpanne <unknown>2004-11-06 14:15:06 +0000
committerpanne <unknown>2004-11-06 14:15:06 +0000
commitd3e04736ab1553825bcf56ed7f1da1fcc478fc99 (patch)
tree5ef17ab5910e429a5ef15f44526b19b5bf3833c9 /libraries/base/configure.ac
parentba2b38ae64194136b64392c811e64fc8b1209bef (diff)
downloadhaskell-d3e04736ab1553825bcf56ed7f1da1fcc478fc99.tar.gz
[project @ 2004-11-06 14:15:06 by panne]
* Re-enable large file support * No need to test for lchown here
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index 8205f0e66d..558f28f3ab 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -11,7 +11,9 @@ AC_CHECK_TYPES([long long])
# check for specific header (.h) files that we are interested in
AC_CHECK_HEADERS([ctype.h fcntl.h signal.h sys/resource.h termios.h time.h])
-AC_CHECK_HEADER([unistd.h], [AC_CHECK_FUNCS(lchown)])
+# Enable large file support. Do this before testing the types ino_t, off_t, and
+# rlim_t, because it will affect the result of that test.
+AC_SYS_LARGEFILE
# map standard C types and ISO types to Haskell types
FPTOOLS_CHECK_HTYPE(char)