summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2011-06-12 12:59:04 +0100
committerIan Lynagh <igloo@earth.li>2011-06-12 13:00:57 +0100
commit119deaae96ca8a02997d4c1c6a28f3f380c3d24f (patch)
tree8b1a5394fd2bfbb8cb28029ade22fe985ca937a3 /libraries/base/configure.ac
parentb5655068fdd2e9b373581606f364b953af636e51 (diff)
downloadhaskell-119deaae96ca8a02997d4c1c6a28f3f380c3d24f.tar.gz
In configure, set $WINDOWS to YES or NO
rather than inlining the implementation of the test.
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index b19e8008ff..1cf01a4c64 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -10,6 +10,13 @@ AC_ARG_WITH([cc],
[CC=$withval])
AC_PROG_CC()
+case `uname -s` in
+ MINGW*|CYGWIN*)
+ WINDOWS=YES;;
+ *)
+ WINDOWS=NO;;
+esac
+
# do we have long longs?
AC_CHECK_TYPES([long long])
@@ -138,11 +145,10 @@ FP_SEARCH_LIBS_PROTO(iconv,
iconv_close(cd);],
iconv,
[EXTRA_LIBS="$EXTRA_LIBS $ac_lib"],
- [case `uname -s` in
- MINGW*|CYGWIN*) ;;
- *)
- AC_MSG_ERROR([iconv is required on non-Windows platforms]);;
- esac])
+ [if test "$WINDOWS" = "NO"
+ then
+ AC_MSG_ERROR([iconv is required on non-Windows platforms])
+ fi])
# If possible, we use libcharset instead of nl_langinfo(CODESET) to
# determine the current locale's character encoding.