summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorHerbert Valerio Riedel <hvr@gnu.org>2015-12-14 07:36:37 +0100
committerHerbert Valerio Riedel <hvr@gnu.org>2015-12-14 08:06:46 +0100
commitfcc6b1def57d3009f9a3662a96d87ee041eb49b8 (patch)
treefff99016bef3f2c5fc6c36eb3775c3ba0e86bf02 /libraries/base/configure.ac
parent0bf0cf936c7895b19d0fd6a19d5238eed6c8feb6 (diff)
downloadhaskell-fcc6b1def57d3009f9a3662a96d87ee041eb49b8.tar.gz
Use idiomatic way to tell Autoconf the c compiler
The non-idiomatic `--with-cc` flag was added via 5c789e424c1461c1dadfd38c44fcb9e8f38bf755 However, `--with-cc` seems rather fragile and support for `--with-cc` needs to be added explicitly to autoconf-based Cabal packages. The `CC=` flag, however, is supported natively by GNU Autoconf, so let's use the standard facility for that. Relatedly, Cabal prior to version 1.24 used a similiar flag `--with-gcc=...`, but starting with Cabal-1.24 this has been changed to use `CC=...` instead as well (see https://github.com/haskell/cabal/pull/2946) This also updates a few submodules removing the now obsolete `--with-cc` flag support. Reviewed By: trofi, thomie, erikd Differential Revision: https://phabricator.haskell.org/D1608
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index 3d372d7713..b8a4774140 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -10,10 +10,7 @@ AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
-AC_ARG_WITH([cc],
- [C compiler],
- [CC=$withval])
-AC_PROG_CC()
+AC_PROG_CC
dnl make extensions visible to allow feature-tests to detect them lateron
AC_USE_SYSTEM_EXTENSIONS