summaryrefslogtreecommitdiff
path: root/libraries/ghc-bignum/configure.ac
diff options
context:
space:
mode:
authorSylvain Henry <sylvain@haskus.fr>2021-02-12 16:38:29 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-02-16 04:36:02 -0500
commit42ab06f793c0164e2b60acc018ca37d91b46999a (patch)
tree442f96b58ea78c6706d485bdaabbfda06a8e8362 /libraries/ghc-bignum/configure.ac
parenta01e78cc5badff447f4b242ef79f24ea8c9ff1cf (diff)
downloadhaskell-42ab06f793c0164e2b60acc018ca37d91b46999a.tar.gz
Replace more autotools obsolete macros (#19189)
Diffstat (limited to 'libraries/ghc-bignum/configure.ac')
-rw-r--r--libraries/ghc-bignum/configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/libraries/ghc-bignum/configure.ac b/libraries/ghc-bignum/configure.ac
index 1c658fdb70..b237978740 100644
--- a/libraries/ghc-bignum/configure.ac
+++ b/libraries/ghc-bignum/configure.ac
@@ -16,31 +16,31 @@ dnl * Deal with arguments telling us gmp is somewhere odd
dnl--------------------------------------------------------------------
AC_ARG_WITH([gmp],
- [AC_HELP_STRING([--with-gmp],
+ [AS_HELP_STRING([--with-gmp],
[Enable GMP backend])],
[GMP_ENABLED=YES],
[GMP_ENABLED=NO])
AC_ARG_WITH([gmp-includes],
- [AC_HELP_STRING([--with-gmp-includes],
+ [AS_HELP_STRING([--with-gmp-includes],
[directory containing gmp.h])],
[GMP_INCLUDE_DIRS=$withval; CPPFLAGS="-I$withval"],
[GMP_INCLUDE_DIRS=])
AC_ARG_WITH([gmp-libraries],
- [AC_HELP_STRING([--with-gmp-libraries],
+ [AS_HELP_STRING([--with-gmp-libraries],
[directory containing gmp library])],
[GMP_LIB_DIRS=$withval; LDFLAGS="-L$withval"],
[GMP_LIB_DIRS=])
AC_ARG_WITH([gmp-framework-preferred],
- [AC_HELP_STRING([--with-gmp-framework-preferred],
+ [AS_HELP_STRING([--with-gmp-framework-preferred],
[on OSX, prefer the GMP framework to the gmp lib])],
[GMP_PREFER_FRAMEWORK=YES],
[GMP_PREFER_FRAMEWORK=NO])
AC_ARG_WITH([intree-gmp],
- [AC_HELP_STRING([--with-intree-gmp],
+ [AS_HELP_STRING([--with-intree-gmp],
[force using the in-tree GMP])],
[GMP_FORCE_INTREE=YES],
[GMP_FORCE_INTREE=NO])