summaryrefslogtreecommitdiff
path: root/.gitlab/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to '.gitlab/shell.nix')
-rw-r--r--.gitlab/shell.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/.gitlab/shell.nix b/.gitlab/shell.nix
index 5e32847735..37e6585879 100644
--- a/.gitlab/shell.nix
+++ b/.gitlab/shell.nix
@@ -18,11 +18,16 @@
#
# nix has the ugly habbit of duplicating ld flags more than necessary. This
# somewhat consolidates this.
- shellHook = ''
+ shellHook = (with pkgs.haskell; ''
export NIX_LDFLAGS=$(for a in $NIX_LDFLAGS; do echo $a; done |sort|uniq|xargs)
export NIX_LDFLAGS_FOR_TARGET=$(for a in $NIX_LDFLAGS_FOR_TARGET; do echo $a; done |sort|uniq|xargs)
export NIX_LDFLAGS_FOR_TARGET=$(comm -3 <(for l in $NIX_LDFLAGS_FOR_TARGET; do echo $l; done) <(for l in $NIX_LDFLAGS; do echo $l; done))
- '';
+
+ export GHC=${compiler.${compiler}}/bin/ghc
+ export ALEX=${packages.${compiler}.alex}/bin/alex
+ export HAPPY=${packages.${compiler}.happy}/bin/happy
+ export CABAL=${packages.${compiler}.cabal-install}/bin/cabal
+ '');
nativeBuildInputs = (with pkgs; [
haskell.compiler.${compiler}