summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 1 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index a62f092877..c8ef451e5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -642,39 +642,7 @@ FP_PROG_LD_FILELIST
dnl ** Which nm to use?
dnl --------------------------------------------------------------
-if test "$HostOS" != "mingw32"; then
- AC_CHECK_TARGET_TOOL([NM], [nm])
- if test "$NM" = ":"; then
- AC_MSG_ERROR([cannot find nm in your PATH])
- fi
-fi
-NmCmd="$NM"
-AC_SUBST([NmCmd])
-
-if test "$TargetOS_CPP" = "darwin"
-then
- AC_MSG_CHECKING(whether nm program is broken)
- # Some versions of Xcode ship a broken version of `nm`. Detect and work
- # around this issue. See : https://gitlab.haskell.org/ghc/ghc/issues/11744
- nmver=$(${NM} --version | grep version | sed 's/ //g')
- case "$nmver" in
- LLVMversion7.3.0|LLVMversion7.3.1)
- AC_MSG_RESULT(yes)
- echo "The detected nm program is broken."
- echo
- echo "See: https://gitlab.haskell.org/ghc/ghc/issues/11744"
- echo
- echo "Try re-running configure with:"
- echo
- echo ' NM=$(xcrun --find nm-classic) ./configure'
- echo
- exit 1
- ;;
- *)
- AC_MSG_RESULT(no)
- ;;
- esac
-fi
+FP_FIND_NM
dnl ** Which objdump to use?
dnl --------------------------------------------------------------