summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7f2fb42bc6..01b9727483 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,7 +13,7 @@ dnl
# see what flags are available. (Better yet, read the documentation!)
#
-AC_INIT([The Glorious Glasgow Haskell Compilation System], [9.3], [glasgow-haskell-bugs@haskell.org], [ghc-AC_PACKAGE_VERSION])
+AC_INIT([The Glorious Glasgow Haskell Compilation System],[9.3],[glasgow-haskell-bugs@haskell.org],[ghc-AC_PACKAGE_VERSION])
# Version on master must be X.Y (not X.Y.Z) for ProjectVersionMunged variable
# to be useful (cf #19058). However, the version must have three components
# (X.Y.Z) on stable branches (e.g. ghc-9.2) to ensure that pre-releases are
@@ -83,18 +83,18 @@ dnl * We need 2.52 due to the use of AS_TR_CPP and AS_TR_SH.
dnl * Using autoconf 2.59 started to give nonsense like this
dnl #define SIZEOF_CHAR 0
dnl recently.
-AC_PREREQ([2.69])
+AC_PREREQ([2.71])
# -------------------------------------------------------------------------
# Prepare to generate the following header files
#
# This one is autogenerated by autoheader.
-AC_CONFIG_HEADER(mk/config.h)
+AC_CONFIG_HEADERS([mk/config.h])
# This one is manually maintained.
-AC_CONFIG_HEADER(compiler/ghc-llvm-version.h)
+AC_CONFIG_HEADERS([compiler/ghc-llvm-version.h])
dnl manually outputted above, for reasons described there.
-dnl AC_CONFIG_HEADER(rts/include/ghcversion.h)
+dnl AC_CONFIG_HEADERS([rts/include/ghcversion.h])
# No, semi-sadly, we don't do `--srcdir'...
if test x"$srcdir" != 'x.' ; then
@@ -146,7 +146,7 @@ if test "$EnableDistroToolchain" = "YES"; then
fi
AC_ARG_ENABLE(asserts-all-ways,
-[AC_HELP_STRING([--enable-asserts-all-ways],
+[AS_HELP_STRING([--enable-asserts-all-ways],
[Usually ASSERTs are only compiled in the DEBUG way,
this will enable them in all ways.])],
[FP_CAPITALIZE_YES_NO(["$enableval"], [EnableAssertsAllWays])],
@@ -881,9 +881,6 @@ AC_CHECK_HEADERS([sys/cpuset.h], [], [],
dnl ** check whether a declaration for `environ` is provided by libc.
FP_CHECK_ENVIRON
-dnl ** check if it is safe to include both <time.h> and <sys/time.h>
-AC_HEADER_TIME
-
dnl ** do we have long longs?
AC_CHECK_TYPES([long long])