summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0af10c19ec..22801c99a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -428,6 +428,21 @@ FP_ARG_WITH_PATH_GNU_PROG([LD], [ld])
LdCmd="$LD"
AC_SUBST([LdCmd])
+dnl ** Check for dlltool on Windows
+dnl --------------------------------------------------------------
+case $HostOS_CPP in
+cygwin32|mingw32)
+ AC_PATH_PROG(DlltoolCmd,dlltool)
+ if test -z "$DlltoolCmd"; then
+ echo "Can't find dlltool in your path, can't make DLLs."
+ exit 1
+ fi
+ ;;
+*)
+ AC_SUBST(DlltoolCmd,"")
+ ;;
+esac
+
dnl ** Which nm to use?
dnl --------------------------------------------------------------
FP_ARG_WITH_PATH_GNU_PROG([NM], [nm])