summaryrefslogtreecommitdiff
path: root/compiler/GHC/Core/Utils.hs
Commit message (Expand)AuthorAgeFilesLines
* Drop absent bindings in worker/wrapperSimon Peyton Jones2021-06-051-3/+9
* WW: Mark absent errors as diverging againSebastian Graf2021-06-021-4/+1
* Remove useless {-# LANGUAGE CPP #-} pragmasSylvain Henry2021-05-121-7/+3
* Fully remove HsVersions.hSylvain Henry2021-05-121-9/+7
* Replace CPP assertions with Haskell functionsSylvain Henry2021-05-121-10/+12
* Make sized division primops ok-for-spec (#19026)Sylvain Henry2021-04-301-14/+1
* Replace (ptext .. sLit) with `text`Sylvain Henry2021-04-291-1/+1
* Refactor around `wantToUnbox`Sebastian Graf2021-04-201-1/+1
* Factor out DynFlags from WorkWrap.UtilsSebastian Graf2021-04-201-1/+13
* Rubbish literals for all representations (#18983)Sebastian Graf2021-03-261-3/+6
* Transfer tickish things to GHC.Types.TickishLuite Stegeman2021-03-201-0/+1
* rename Tickish to CoreTickishLuite Stegeman2021-03-201-14/+16
* remove superfluous 'id' type parameter from GenTickishLuite Stegeman2021-03-201-12/+12
* Save the type of breakpoints in the Breakpoint tick in STGLuite Stegeman2021-03-201-1/+1
* Fix over-eager inlining in SimpleOptSimon Peyton Jones2021-02-141-4/+29
* Introduce keepAlive primopBen Gamari2021-02-141-0/+2
* Add explicit import lists to Data.List importsOleg Grenrus2021-01-291-1/+1
* Core: introduce Alt/AnnAlt/IfaceAlt datatypesSylvain Henry2021-01-221-38/+38
* Don't use absentError thunks for strict constructor fieldsSimon Peyton Jones2021-01-021-1/+1
* Add the proper HLint rules and remove redundant keywords from compilerHécate2020-11-011-2/+1
* Remove unnecessary gender from comments/docsRichard Eisenberg2020-10-291-2/+1
* Misc cleanupKrzysztof Gogolewski2020-10-071-2/+1
* Fix typos in commentsKrzysztof Gogolewski2020-10-021-1/+1
* DynFlags: disentangle OutputableSylvain Henry2020-08-121-0/+3
* Clean up haddock hyperlinks of GHC.* (part1)Takenobu Tani2020-06-251-2/+2
* Various performance improvementsKrzysztof Gogolewski2020-06-171-5/+39
* Linear types (#15981)Krzysztof Gogolewski2020-06-171-23/+56
* Implement cast worker/wrapper properlySimon Peyton Jones2020-06-101-1/+21
* Rename GHC.Core.Arity into GHC.Core.Opt.AritySylvain Henry2020-05-241-1/+1
* DmdAnal: Improve handling of precise exceptionsSebastian Graf2020-05-151-10/+9
* Modules: Utils and Data (#13009)Sylvain Henry2020-04-261-10/+10
* Mark DataCon wrappers CONLIKEAlexis King2020-04-221-9/+8
* Modules (#13009)Sylvain Henry2020-04-181-6/+6
* GHC.Core.Opt renamingSylvain Henry2020-04-181-15/+15
* Re-engineer the binder-swap transformationSimon Peyton Jones2020-04-021-86/+53
* Modules: Types (#13009)Sylvain Henry2020-03-291-12/+12
* DynFlags refactoring IIISylvain Henry2020-03-251-4/+4
* Modules: Core operations (#13009)Sylvain Henry2020-03-181-18/+19
* Modules: Core (#13009)Sylvain Henry2020-03-161-6/+6
* Remove some dead codeBrian Foley2020-03-151-14/+1
* Improve CSE.combineAltsSimon Peyton Jones2020-03-141-4/+21
* Simple refactor of cheapEqExprSimon Peyton Jones2020-03-141-16/+14
* Typos in comments [skip ci]Krzysztof Gogolewski2020-03-101-1/+1
* Modules: Core (#13009)Sylvain Henry2020-02-261-0/+2567