summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomek Mrugalski <tomek@isc.org>2022-03-30 16:26:33 +0200
committerTomek Mrugalski <tomek@isc.org>2022-03-30 16:26:33 +0200
commit9cd5f3a69c70fe9caaf44f75a29d6e74f884d170 (patch)
tree819eed32a4868541ce818d1b56c712575609c24c /configure.ac
parenteb1ba1340e5ea8fa102ffd4b52ff01d13b00dbd1 (diff)
downloadisc-dhcp-9cd5f3a69c70fe9caaf44f75a29d6e74f884d170.tar.gz
[#227] Removed bunch of configure options
--with-cli-lease-file, --with-cli6-lease-file --with-cli-pid-file, --with-cli6-pid-file --with-relay-pid-file, --with-relay6-pid-file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac82
1 files changed, 1 insertions, 81 deletions
diff --git a/configure.ac b/configure.ac
index b22f4586..fc99a22d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,7 +177,7 @@ else
enable_dhcpv4o6="no"
fi
-# Relay port (draft-ietf-dhc-relay-port-10.txt) optional compile-time feature.
+# Relay port (RFC8357) optional compile-time feature.
AC_ARG_ENABLE(relay-port,
AS_HELP_STRING([--enable-relay-port],[enable support for relay port (default is no)]))
# Relay port is off by default (for now)
@@ -398,66 +398,6 @@ if [[ "x$with_srv6_lease_file" = "x" ]] ; then
fi
AC_MSG_RESULT($with_srv6_lease_file)
-AC_ARG_WITH(cli-lease-file,
- AS_HELP_STRING([--with-cli-lease-file=PATH],[File for dhclient leases
- (default is LOCALSTATEDIR/db/dhclient.leases)]),
- AC_DEFINE_UNQUOTED([_PATH_DHCLIENT_DB], ["$withval"],
- [File for dhclient leases.]))
-
-AC_MSG_CHECKING([for dhclient.leases location])
-if [[ "x$with_cli_lease_file" = "x" ]] ; then
- if [[ -d "${localstatedir}/db" ]] ; then
- with_cli_lease_file="${localstatedir}/db/dhclient.leases"
- elif [[ -d "${localstatedir}/state" ]] ; then
- if [[ -d "${localstatedir}/state/dhcp" ]] ; then
- with_cli_lease_file="${localstatedir}/state/dhcp/dhclient.leases"
- else
- with_cli_lease_file="${localstatedir}/state/dhclient.leases"
- fi
- elif [[ -d "${localstatedir}/lib" ]] ; then
- if [[ -d "${localstatedir}/lib/dhcp" ]] ; then
- with_cli_lease_file="${localstatedir}/lib/dhcp/dhclient.leases"
- else
- with_cli_lease_file="${localstatedir}/lib/dhclient.leases"
- fi
- elif [[ -d "${localstatedir}/etc" ]] ; then
- with_cli_lease_file="${localstatedir}/etc/dhclient.leases"
- else
- with_cli_lease_file="/etc/dhclient.leases"
- fi
-fi
-AC_MSG_RESULT($with_cli_lease_file)
-
-AC_ARG_WITH(cli6-lease-file,
- AS_HELP_STRING([--with-cli6-lease-file=PATH],[File for dhclient6 leases
- (default is LOCALSTATEDIR/db/dhclient6.leases)]),
- AC_DEFINE_UNQUOTED([_PATH_DHCLIENT6_DB], ["$withval"],
- [File for dhclient6 leases.]))
-
-AC_MSG_CHECKING([for dhclient6.leases location])
-if [[ "x$with_cli6_lease_file" = "x" ]] ; then
- if [[ -d "${localstatedir}/db" ]] ; then
- with_cli6_lease_file="${localstatedir}/db/dhclient6.leases"
- elif [[ -d "${localstatedir}/state" ]] ; then
- if [[ -d "${localstatedir}/state/dhcp" ]] ; then
- with_cli6_lease_file="${localstatedir}/state/dhcp/dhclient6.leases"
- else
- with_cli6_lease_file="${localstatedir}/state/dhclient6.leases"
- fi
- elif [[ -d "${localstatedir}/lib" ]] ; then
- if [[ -d "${localstatedir}/lib/dhcp" ]] ; then
- with_cli6_lease_file="${localstatedir}/lib/dhcp/dhclient6.leases"
- else
- with_cli6_lease_file="${localstatedir}/lib/dhclient6.leases"
- fi
- elif [[ -d "${localstatedir}/etc" ]] ; then
- with_cli6_lease_file="${localstatedir}/etc/dhclient6.leases"
- else
- with_cli6_lease_file="/etc/dhclient6.leases"
- fi
-fi
-AC_MSG_RESULT($with_cli6_lease_file)
-
AC_ARG_WITH(srv-pid-file,
AS_HELP_STRING([--with-srv-pid-file=PATH],[File for dhcpd process information
(default is LOCALSTATEDIR/run/dhcpd.pid)]),
@@ -468,26 +408,6 @@ AC_ARG_WITH(srv6-pid-file,
(default is LOCALSTATEDIR/run/dhcpd6.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCPD6_PID], ["$withval"],
[File for dhcpd6 process information.]))
-AC_ARG_WITH(cli-pid-file,
- AS_HELP_STRING([--with-cli-pid-file=PATH],[File for dhclient process information
- (default is LOCALSTATEDIR/run/dhclient.pid)]),
- AC_DEFINE_UNQUOTED([_PATH_DHCLIENT_PID], ["$withval"],
- [File for dhclient process information.]))
-AC_ARG_WITH(cli6-pid-file,
- AS_HELP_STRING([--with-cli6-pid-file=PATH],[File for dhclient6 process information
- (default is LOCALSTATEDIR/run/dhclient6.pid)]),
- AC_DEFINE_UNQUOTED([_PATH_DHCLIENT6_PID], ["$withval"],
- [File for dhclient6 process information.]))
-AC_ARG_WITH(relay-pid-file,
- AS_HELP_STRING([--with-relay-pid-file=PATH],[File for dhcrelay process information
- (default is LOCALSTATEDIR/run/dhcrelay.pid)]),
- AC_DEFINE_UNQUOTED([_PATH_DHCRELAY_PID], ["$withval"],
- [File for dhcrelay process information.]))
-AC_ARG_WITH(relay6-pid-file,
- AS_HELP_STRING([--with-relay6-pid-file=PATH],[File for dhcrelay6 process information
- (default is LOCALSTATEDIR/run/dhcrelay6.pid)]),
- AC_DEFINE_UNQUOTED([_PATH_DHCRELAY6_PID], ["$withval"],
- [File for dhcrelay6 process information.]))
# Check basic types.
AC_TYPE_INT8_T