summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShawn Routhier <sar@isc.org>2010-09-14 22:20:20 +0000
committerShawn Routhier <sar@isc.org>2010-09-14 22:20:20 +0000
commit4e0997c6c2ede21b7cd135ec25175b1a8f69498f (patch)
treec9e94341965ae8f2ba5e80caca2d7eceebb14234 /configure.ac
parenta96cdbe1f80bb9a5493eb2c2d40da79cfe74f13b (diff)
downloadisc-dhcp-4e0997c6c2ede21b7cd135ec25175b1a8f69498f.tar.gz
Minor changes for scripts, configure.ac and Makefiles
[ISC-Bugs #19147] Use domain-search instead of domain-name in manual and example conf file. Thanks to a patch from David Cantrell at Red Hat. [ISC-Bugs #19761] Restore address when doing a rebind in DHCPv6 [ISC-Bugs #19945] Properly close the quote on some arguments. [ISC-Bugs #20952] Add 64 bit types to configure.ac [ISC-Bugs #21308] Add "PATH=" to CLIENT_PATH envrionment variable
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ff832aa6..87073690 100644
--- a/configure.ac
+++ b/configure.ac
@@ -322,6 +322,7 @@ AC_ARG_WITH(relay-pid-file,
AC_TYPE_INT8_T
AC_TYPE_INT16_T
AC_TYPE_INT32_T
+AC_TYPE_INT64_T
# Some systems need the u_intX_t types defined across.
AC_CHECK_TYPE([u_int8_t], [], [
@@ -339,6 +340,11 @@ AC_CHECK_TYPE([u_int32_t], [], [
AC_DEFINE(u_int32_t, [uint32_t], [Define a type for 32-bit unsigned
integers.])
])
+AC_CHECK_TYPE([u_int64_t], [], [
+ AC_TYPE_UINT64_T
+ AC_DEFINE(u_int64_t, [uint64_t], [Define a type for 64-bit unsigned
+ integers.])
+])
# see if ifaddrs.h is available
AC_CHECK_HEADERS(ifaddrs.h)