summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2015-11-17 14:55:09 +0100
committerFrancis Dupont <fdupont@isc.org>2015-11-17 14:55:09 +0100
commita555d1ab9ff099e4bf278ba416188b7491f51f7f (patch)
treea96633bd93e868f56dc99e5ef729716713191363 /configure.ac
parentce29e695745f3a660f0a0cd9e43b4b1c41bb8276 (diff)
parent2830c4005906378b3f14bcb8c146a156268bc3dc (diff)
downloadisc-dhcp-a555d1ab9ff099e4bf278ba416188b7491f51f7f.tar.gz
Finished merge of rt39210 (--with-libbind fixes) (regen required)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 16 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5dd966f9..39c0a28a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -611,25 +611,34 @@ AC_CHECK_MEMBER(struct tpacket_auxdata.tp_vlan_tci,
[AC_DEFINE([VLAN_TCI_PRESENT], [1], [tpacket_auxdata.tp_vlan_tci present])]
,, [#include <linux/if_packet.h>])
-libbind=
+BINDDIR=
AC_ARG_WITH(libbind,
AS_HELP_STRING([--with-libbind=PATH],[bind includes and libraries are in PATH
(default is ./bind)]),
use_libbind="$withval", use_libbind="no")
case "$use_libbind" in
yes)
- libbind="\${top_srcdir}/bind"
+ BINDDIR="\${top_srcdir}/bind"
;;
no)
- libbind="\${top_srcdir}/bind"
+ BINDDIR="\${top_srcdir}/bind"
;;
*)
- libbind="$use_libbind"
+ BINDDIR="$use_libbind"
if test ! -d "bind"; then
- AC_MSG_WARN(empty bind directory)
- fi
+ # no bind directory, create it with a fake Makefile.in
+ # (AC_CONFIG_FILES and top Makefile refer to it so
+ # it must exits)
+ mkdir bind
+ cat > bind/Makefile.in << EOF
+# placeholder
+all check clean distclean distdir install uninstall:
+
+EOF
+ fi
;;
esac
+AC_SUBST(BINDDIR)
# OpenLDAP support.
AC_ARG_WITH(ldap,
@@ -707,7 +716,7 @@ fi
CFLAGS="$CFLAGS $STD_CWARNINGS"
# Try to add the bind include directory
-CFLAGS="$CFLAGS -I$libbind/include"
+CFLAGS="$CFLAGS -I$BINDDIR/include"
case "$host" in
*-darwin*)