summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2015-11-17 15:13:29 +0100
committerFrancis Dupont <fdupont@isc.org>2015-11-17 15:13:29 +0100
commite2f36ff16f7de5fb6e028354a2cc04a181e887b4 (patch)
tree492142cf58092c699e771983504c4cafdaecd14c /configure.ac
parenta555d1ab9ff099e4bf278ba416188b7491f51f7f (diff)
parentb4a10c76f139f8070780b71366fcc083cbb1f126 (diff)
downloadisc-dhcp-e2f36ff16f7de5fb6e028354a2cc04a181e887b4.tar.gz
Merged rt38836b (cross compile)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 39c0a28a..b6bf9c87 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,11 @@ fi
# We can have some flags to pass to bind configure
BINDCONFIG=
+if test "$cross_compiling" = "yes"; then
+ BINDCONFIG="--host=$host"
+fi
AC_SUBST(BINDCONFIG)
+AM_CONDITIONAL(CROSS_COMPILING, test "$cross_compiling" = "yes")
# POSIX doesn't include the IPv6 Advanced Socket API and glibc hides
# parts of the IPv6 Advanced Socket API as a result. This is stupid