summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e471a2a..ceb5dd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -233,6 +233,10 @@ if(BUILD_SHARED_LIBS)
# Used by include/export.h.
LEVELDB_SHARED_LIBRARY
)
+ set_target_properties(leveldb
+ PROPERTIES VERSION ${PROJECT_VERSION})
+ set_target_properties(leveldb
+ PROPERTIES SOVERSION 1)
endif(BUILD_SHARED_LIBS)
if(HAVE_CLANG_THREAD_SAFETY)