summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric N. Vander Weele <ericvw@gmail.com>2016-03-18 18:51:25 -0400
committerEric N. Vander Weele <ericvw@gmail.com>2016-03-18 18:51:25 -0400
commit9f6c6d5d69209eefb2a1ecc4ca508840465dff63 (patch)
tree38384b6b2202e8ca94c9828975771de9747fa06e /configure.ac
parentdf2b46bf40d073bc9547c4c96f486a1fa05bd4cc (diff)
downloadlibarchive-9f6c6d5d69209eefb2a1ecc4ca508840465dff63.tar.gz
Dynamically determine supported compiler flags during configure
Some compilers (e.g., `xlc` on AIX) don't support GCC compiler flags. This change dynamically tests for supported `COMMON_FLAGS`, which get appended to `CFLAGS`. Signed-off-by: Eric N. Vander Weele <ericvw@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d353754f..487b60bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,6 +472,9 @@ fi
# -larchive in that case.
#AC_CHECK_LIB(archive,archive_version)
+# Checks for supported compiler flags
+AX_APPEND_COMPILE_FLAGS([-Wall -Wformat -Wformat-security])
+
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
# la_TYPE_UID_T defaults to "int", which is incorrect for MinGW