summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoerg Sonnenberger <joerg@bec.de>2016-06-23 15:16:16 +0200
committerJoerg Sonnenberger <joerg@bec.de>2016-06-23 15:16:16 +0200
commite7642e12ea7636933cfaeecef1b26daf6490ad52 (patch)
tree14db9eda620a91895ef652efed69fa9360a711e8 /configure.ac
parent11f5b75c9ba12ba73b5fa34dc9d285983d99c01b (diff)
downloadlibarchive-e7642e12ea7636933cfaeecef1b26daf6490ad52.tar.gz
For getvfsbyname on DragonFly, struct vfsconf has to be used and not
struct xvfsconf as on FreeBSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f7f432a..bda5e6eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -616,6 +616,14 @@ AC_CHECK_FUNCS([_get_timezone _localtime64_s _mkgmtime64])
# detects cygwin-1.7, as opposed to older versions
AC_CHECK_FUNCS([cygwin_conv_path])
+# DragonFly uses vfsconf, FreeBSD xvfsconf.
+AC_CHECK_TYPES(struct vfsconf,,,
+ [#if HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
+ #include <sys/mount.h>
+ ])
+
# There are several variants of readdir_r around; we only
# accept the POSIX-compliant version.
AC_COMPILE_IFELSE(