summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2011-08-10 13:18:24 +0200
committerWerner Koch <wk@gnupg.org>2011-08-10 13:18:24 +0200
commit01bc9280de76159be9512530b18d73488b269476 (patch)
treeb2feb396ad80970d2e648eb6e020744e9fa467c8 /configure.ac
parent02c13554c5a5c44556acb9ff4e4b380f92a98b7d (diff)
downloadlibassuan-01bc9280de76159be9512530b18d73488b269476.tar.gz
Update libtool and other framework stuff.
- Libtool is now at version 2.4. - Fixed the newer autoconf warnings. - Updated config.{guess,sub} to a more modern version; we used a 4 years old version.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 983a2b3..b0e9e34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,17 +24,17 @@ min_automake_version="1.10"
# Remember to change the version number immediately *after* a release.
# Set my_issvn to "yes" for non-released code. Remember to run an
# "svn up" and "autogen.sh" right before creating a distribution.
-m4_define([my_version], [2.0.2])
+m4_define([my_version], [2.0.3])
m4_define([my_issvn], [yes])
m4_define([svn_revision], m4_esyscmd([printf "%d" $( (svn info 2>/dev/null \
|| echo 'Revision: 0')|sed -n '/^Revision:/ {s/[^0-9]//gp;q;}')]))
m4_define([git_revision], m4_esyscmd([git branch -v 2>/dev/null \
| awk '/^\* / {printf "%s",$3}']))
-AC_INIT([libassuan],
- [my_version[]m4_if(my_issvn,[yes],
- [m4_if(git_revision,[],[-svn[]svn_revision],[-git[]git_revision])])],
- [bug-libassuan@gnupg.org])
+m4_define([my_full_version], [my_version[]m4_if(my_issvn,[yes],
+ [m4_if(git_revision,[],[-svn[]svn_revision],[-git[]git_revision])])])
+
+AC_INIT([libassuan],[my_full_version],[http://bugs.gnupg.org])
# LT Version numbers, remember to change them just *before* a release.
# (Code changed: REVISION++)
@@ -155,7 +155,7 @@ if test "$GCC" = yes; then
AC_MSG_CHECKING([if gcc supports -Wpointer-arith])
_gcc_cflags_save=$CFLAGS
CFLAGS="-Wpointer-arith"
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),_gcc_wopt=yes,_gcc_wopt=no)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([])],_gcc_wopt=yes,_gcc_wopt=no)
AC_MSG_RESULT($_gcc_wopt)
CFLAGS=$_gcc_cflags_save;
if test x"$_gcc_wopt" = xyes ; then