summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2010-03-16 13:04:42 +0000
committerWerner Koch <wk@gnupg.org>2010-03-16 13:04:42 +0000
commit4266559927264f0cce31b07a207dbd23d578e147 (patch)
treee39ae18aa481faf05da4419592972e37d6a407d5 /src/Makefile.am
parent59cc5ffd3b6092adb8d382aa3faf71571525c185 (diff)
downloadlibassuan-4266559927264f0cce31b07a207dbd23d578e147.tar.gz
Refactored platform system code.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6403e79..c946f11 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -57,6 +57,17 @@ common_sources = \
assuan-socket.c
if HAVE_W32_SYSTEM
+if HAVE_W32CE_SYSTEM
+common_sources += system-w32ce.c
+else
+common_sources += system-w32.c
+endif
+else
+common_sources += system-posix.c
+endif
+
+
+if HAVE_W32_SYSTEM
LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
`echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \