summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2010-03-22 12:16:18 +0000
committerWerner Koch <wk@gnupg.org>2010-03-22 12:16:18 +0000
commitf807c38fc5e6b703b85fe86ea8946c9f42bc3e53 (patch)
treeb1467ffba675527d6dafe50c9c6b8b200b8e7026 /src/Makefile.am
parent4266559927264f0cce31b07a207dbd23d578e147 (diff)
downloadlibassuan-f807c38fc5e6b703b85fe86ea8946c9f42bc3e53.tar.gz
Changed the implementation of CreatePipe under W32CE.
Reorganized the source.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c946f11..6723648 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,5 @@
# Assuan Makefile
-# Copyright (C) 2001, 2002, 2003, 2009 Free Software Foundation, Inc.
+# Copyright (C) 2001, 2002, 2003, 2009, 2010 Free Software Foundation, Inc.
#
# This file is part of Assuan.
#
@@ -18,7 +18,7 @@
## Process this file with automake to produce Makefile.in
EXTRA_DIST = libassuan-config.in libassuan.m4 libassuan.vers \
- versioninfo.rc.in libassuan.def
+ versioninfo.rc.in libassuan.def mkheader.c
INCLUDES = -I.. -I$(top_srcdir)/include
bin_SCRIPTS = libassuan-config
@@ -37,8 +37,12 @@ else
libassuan_version_script_cmd =
endif
+CLEANFILES = mkheader assuan.h
+
+BUILT_SOURCES = assuan.h
common_sources = \
+ assuan.h.in assuan.h w32ce-add.h \
assuan-defs.h \
assuan.c context.c system.c \
debug.c debug.h conversion.c sysutils.c \
@@ -121,3 +125,10 @@ libgpgcedev_la_DEPENDENCIES = gpgcedev.def
gpgcemgr_SOURCES = gpgcemgr.c
gpgcemgr_CPPFLAGS = $(AM_CPPFLAGS)
endif
+
+mkheader: mkheader.c Makefile
+ $(CC_FOR_BUILD) -I. -I$(srcdir) -o $@ $(srcdir)/mkheader.c
+
+assuan.h: assuan.h.in mkheader w32ce-add.h
+ ./mkheader $(host_os) $(srcdir)/assuan.h.in >$@
+