summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2010-02-24 15:50:55 +0000
committerWerner Koch <wk@gnupg.org>2010-02-24 15:50:55 +0000
commitd20a4d4c79d4f12021383a7aeb5c34a861d858a4 (patch)
treeff2439480e53487d070a20b22faa2fc717b8af63 /tests/Makefile.am
parent09633587a0f0301cfef5a745e58c47afb92fce99 (diff)
downloadlibassuan-d20a4d4c79d4f12021383a7aeb5c34a861d858a4.tar.gz
A couple of changes to eventually fully support W32ce.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c243c27..692748c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,20 +20,25 @@
TESTS_ENVIRONMENT =
-EXTRA_DIST = motd
+EXTRA_DIST = motd ce-createpipe.c
BUILT_SOURCES =
CLEANFILES =
-TESTS = ce-server
+TESTS =
+
+if HAVE_W32CE_SYSTEM
+w32cetools = ce-createpipe
+endif
if USE_DESCRIPTOR_PASSING
TESTS += fdpassing
endif
+
AM_CFLAGS = $(GPG_ERROR_CFLAGS)
noinst_HEADERS = common.h
-noinst_PROGRAMS = $(TESTS)
+noinst_PROGRAMS = $(TESTS) ce-server $(w32cetools)
LDADD = ../src/libassuan.la $(NETLIBS) $(GPG_ERROR_LIBS)